Category Archives: Gráficos

Activando Compiz Fusion en Ubuntu

0
Filed under Config. S.O., Gráficos, Ubuntu 8.10 AMD64

Ha llegado el momento de darle un poco de gracia al escritorio, activando algunos efectos de escritorio de Compiz Fusion como el famoso cubo (toda una declaración de intenciones del futuro de los escritorios gráficos de Linux).

En Ubuntu 8.10 se instala y activa por defecto Compiz Fusion (mi tarjeta gráfica NVIDIA tiene soporte y los drivers privativos están activados), pero las opciones para personalizarlo son mínimas (en Menú > Sistema > Preferencias > Apariencia pestaña Efectos visuales sólo se puede escoger el nivel de efectos entre Ninguno, Normal o Extra). Para aumentar las propiedades de personalización de Compiz Fusion, como se dice en esta página de howtoforge, instalo desde Synaptic el paquete simple-ccsm. Este paquete añade una cuarta opción a la pestaña Efectos visuales, Personalizado, que selecciono. Pulsando en el botón Preferencias puedo cambiar algunos ajustes, aunque las opciones de configuración completas están disponibles en Menú > Sistema > Preferencias > Administrador de Opciones CompizConfig.

Hay que ver cómo se ha simplificado el proceso de instalación de Compiz Fusion hoy en día :)

Haciendo funcionar la tableta Wacom

1
Filed under Config. S.O., Gráficos, Hardware, Kubuntu 7.10 AMD64

Tengo una tableta digitalizadora antigua, una Wacom Graphire1 que se conecta al PC a través del puerto serie y el PS/2.

Logrando que funcione en Kubuntu

Gracias a esta página de The Linux Wacom Proyect me entero de lo que debo hacer. Edito como superusuario /etc/X11/xorg.conf y cambio

Section "InputDevice"
	Identifier	"stylus"
	Driver		"wacom"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier	"eraser"
	Driver		"wacom"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier	"cursor"
	Driver		"wacom"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

por esto:

Section "InputDevice"
	Identifier	"stylus"
	Driver		"wacom"
	Option		"Device"	"/dev/ttyS0"
	Option		"Type"	"stylus"
#	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier	"eraser"
	Driver		"wacom"
	Option		"Device"	"/dev/ttyS0"
	Option		"Type"	"eraser"
#	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier	"cursor"
	Driver		"wacom"
	Option		"Device"	"/dev/ttyS0"
	Option		"Type"	"cursor"
#	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Nota: en una instalación limpia de Kubuntu 7.10 este archivo ha cambiado un poco. Para que la tableta funcione, además de lo anterior hay que ir al final del archivo (por la línea 91) y descomentar las entradas correspondientes para que queden así:

		InputDevice     "stylus"	"SendCoreEvents"
		InputDevice     "cursor"	"SendCoreEvents"
		InputDevice     "eraser"	"SendCoreEvents"

Reinicio el servidor X (pulsando Control+Alt+Backspace) ¡y todo funciona! Lo único que había que hacer era cambiar /dev/input/wacom por /dev/ttyS0 (lo primero, que viene por defecto, sirve para las tabletas USB, no para las antiguas por puerto serie), y comentar (o borrar) Option "ForceDevice" "ISDV4", que sirve únicamente para Tablet PCs.

Configurando GIMP e Inkscape

Para activar las posibilidades que ofrece la tableta en GIMP e Inkscape (como cambiar el tamaño de la brocha al variar la presión) sigo lo que se dice en esta entrada de la documentación de Ubuntu:

  • En GIMP: Archivo > Preferencias: Dispositivos de entrada: Configurar los dispositivos de entrada extendidos… y allí cambiar el Mode de “Disabled” a “Screen” (o “Window”) tanto para el Device “eraser” como para “cursor” y “stylus”.
  • En Inkscape: Archivo > Dispositivos de entrada…, activo los dispositivos igual que en GIMP.

Configurando los parámetros de la tableta

Tal como se dice en la documentación de Ubuntu, editando /etc/X11/xorg.conf se pueden configurar a nuestro gusto los parámetros de la tableta, como por ejemplo la curva de presión. La lista completa de parámetros está en la página de The Linux Wacom Project que mencioné al principio.

Existe un paquete, wacom-tools, que contiene algunas utilidades para la prueba y configuración de los parámetros de la tableta (wacdump, xidump y xsetwacom).

Inkscape en español en KDE

1
Filed under Gráficos, Kubuntu 7.10 AMD64

Instalar Inkscape es bien sencillo: desde Adept se instala el paquete inkscape y sus dependencias (al ser para GNOME necesita instalar varias librerías).

El problema viene cuando se abre y está en inglés. Inkscape coge el idioma del sistema, y si no, se pone en el idioma por defecto (inglés). Mi Kubuntu (que usa KDE) está en español, pero es que Inkscape busca el idioma de GNOME. Gracias a este hilo de Ubuntu Forums descubro que para que Inkscape se ponga en español hay que instalar el paquete language-pack-gnome-es.

Recuperar los complementos KIPI desaparecidos en Gwenview

1
Filed under Config. S.O., Gráficos, Kubuntu 7.04 AMD64

Sigo lo que se dice en este hilo del foro de Ubuntu-es: por lo visto, al añadir los repositorios de GetDeb el paquete libgpod1 se actualiza de la versión 0.4.2-0ubuntu2 a 0.5.2.1~getdeb1, provocando que los complementos KIPI no aparezcan desde Gwenview. Para recuperarlos habrá que hacer un downgrade de este paquete:

  1. Me descargo el paquete desde packages.ubuntu.com.
  2. Lo instalo. Me advertirá de que es una desactualización pero instalará el paquete sin ningún problema.

Lo que pasa es que sale un aviso en la barra de tareas de que “Existe 1 paquete actualizado disponible”, y por defecto intentará actualizarse. He logrado que por defecto no intente actualizarse, aunque la advertencia de que “Existe 1 paquete actualizado disponible” sigue saliéndome. Como superusuario creo /etc/apt/preferences con el siguiente contenido:

Package: libgpod1
Pin: version libgpod1_0.4.2-0ubuntu2
Pin-Priority: 1001

Con esto bloqueo el paquete libgpod1 en su versión libgpod1_0.4.2-0ubuntu2.

Otra solución, bastante más basta, sería deshabilitar los repositorios de GetDeb…

A ver cuándo se implementa esto en Adept…